Stress-Optical Effects with Generalized Plane Strain

Page 1 of 16

Optics and Photonics Models : Stress-Optical Effects with Generalized Plane Strain

Stress-Optical Effects with
Generalized Plane Strain
Introduction
The assumptions made for plane strain in the previous analysis of the waveguide structure, in
the model “Stress-Optical Effects in a Silica-on-Silicon Waveguide” on page 258, do not hold in

z direction. Instead it is
necessary to use a generalized plane strain model that allows for free expansion in the z
direction. The boundary conditions in the xy-plane already allow the structure to expand freely
a situation where the silicon-silica laminate is free to expand in the

in all directions in the plane. When the different materials in a laminate expand with different
expansion coefficients, the laminate bends. In this model, the silica-silicon laminate bends in
both the
the

x and z directions. The Plane Strain application mode does not cover the bending in

z direction, so you must make modifications to the plane strain equations at the equation-

system level.
Note: This model requires the RF Module and the Structural Mechanics Module.

Generalized Plane Strain
One possible extension of the plane strain formulation is to assume that the strain in the

z

direction has the form

That is, the strain is linearly varying throughout the cross section. This approximation is
expected to be good when the bending curvature is small with respect to the extents of the

xy-plane and corresponds to a small rotation that is representative of each
cross section of the structure along the z axis. (A more general model would include seconddegree terms in x and y.)
structure in the

One way of validating the result of this simulation is to plot the εx and εz strains on a cross
section on the symmetry line at
and

x = 0. Because you can expect an identical bending in the x

z directions, these strains should be identical and vary linearly.

EXTENSION OF THE PLANE STRAIN EQUATIONS
The objective is to extend the current Plane Strain application mode with additional PDE terms
that represent the generalized plane strain deformation state. In COMSOL Multiphysics, the
coefficients e0, e1, and e2 in the expression for the εz strain is modeled with coupling variables
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associated with a point geometry object (zero dimensional object). This is a convenient way to
include degrees of freedom that are constant throughout a subdomain. In order to expand the
equations for the Plane Strain application mode, the new εz strain contributions need to be
added as weak terms to the ordinary plane strain equations. The reason for this is that for
COMSOL Multiphysics to be able to solve the equations as a linear problem, the assembler
requires that all contributions from coupling variables are entered as weak terms.
Start from the 3D stress-strain relation for linear isotropic conditions including thermal effects,

where σx, σy, σz, τxy, τyz, and τxz are the components of the stress tensor, εx, εy, εz, γxy, γyz, and

γxz are the components of the strain tensor, α is the thermal expansion coefficient, T is the
operating temperature, and

Tref is the reference temperature corresponding to the

D (tensor) has entries that contain
expressions in Young’s modulus, E, and Poisson’s ratio, ν. The matrix D is presented in the
manufacturing temperature. The 6-by-6 matrix
Structural Mechanics Module User’s Guide.
For generalized plane strain (and ordinary plane strain), assume that γyz = γxz = 0 and two of
the equations vanish

The matrix

D shrinks accordingly.

The PDE solved is Navier’s equation

where
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u = (u, v, w) are the unknown displacement

variables solved for.
The coefficient

c above is a tensor containing the elements of D in a pattern that is listed in

the Structural Mechanics Module User’s Guide and

contains the contributions from the thermal strains.
In the case of ordinary plane strain the upper left 2-by-2 submatrix of σ, γ, and
It is assumed here that the variables

D is used.

T and Tref are constants. For information on how the

temperature variables enter Navier’s equation as unknowns in a heat transfer problem, see
the Structural Mechanics Module User’s Guide.
To expand the plane strain equation to a generalized plane strain formulation one needs to
consider the weak form of Navier’s equation. The weak form of a system of equations is a
scalar equation involving integrals. See “Weak Form Modeling” on page 347 in the COMSOL
Multiphysics Modeling Guide for more information on the appearance of the weak form for
systems of equations.
To get the weak form of Navier’s equation, multiply by a test function

v = [utest, vtest, wtest] and

integrate

Integration by parts gives

or in more detail, with

K = 0,
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where uy,test = ∂utest /∂y and similarly for the other test function derivatives. The dot product in
the domain integral is interpreted as a dot product operating on the rows of the matrices so
that

where

and

file:///C:/COMSOL35a/doc/rf/optics_and_photonics_modlib.15.7.html

4/18/2018

Stress-Optical Effects with Generalized Plane Strain

Note that the displacement variable

Page 5 of 16

w in the z direction is not available in the Plane Strain

application mode. However, it is not needed since the generalized formulation assumes a
certain fix shape of the deformation in the

z direction.

The same relations hold for the test functions,

In COMSOL Multiphysics, the test functions utest and vtest are denoted

u_test and v_test,

respectively. Their derivatives ux,test, uy,test, vx,test, and vy,test are denoted

ux_test,

uy_test, vx_test, and vy_test, respectively. Note that the z components of the test
functions are not available in the Plane Strain application mode.
Using this notation, the weak form of Navier’s equation becomes (with

K = 0)

This expression for the weak equation shows which terms you must add as weak terms to
generalize the plane strain formulation.
To see the difference compared to the ordinary plane strain formulation, the equation for σz
can be separated out according to
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D has been reduced to

The ordinary plane strain equation is obtained if εz = 0.
To expand the Plane Strain application mode, you must add weak contributions from εz need
to the stress components σx and σy according to

In addition, σz needs to be included in the weak equation from being merely a postprocessing
quantity in the original Plane Strain application mode,

where

and σz was presented earlier.
In COMSOL Multiphysics you model the coefficients e0, e1, and e2 in the expression for the εz
strain with coupling variables as weak contributions to the ordinary plane strain equations.
These coefficients represent three additional unknown variables that prevail throughout the
modeled domain. In practice, these variables need to be associated with an arbitrary point of
the geometry. Using coupling variables in this way specifies a map from this point onto the
entire domain on which the generalized plane strain equations hold. COMSOL Multiphysics
creates the test functions corresponding to e0, e1, and e2 automatically.
Model Library path:

RF_Module/Optics_and_Photonics/stress_optical_generalized

Modeling Using the Graphical User Interface—Plane Strain
Analysis
Many of the modeling steps are similar to the model “Stress-Optical Effects in a Silica-onSilicon Waveguide” on page 258, but some steps are made in a different order, and there are
obviously differences when generalizing the plane strain problem.

MULTIPHYSICS SETTINGS
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1 In the Model Navigator, select 2D.
2 Select the Structural Mechanics Module>Plane Strain>Static analysis application
mode.

3 Click Multiphysics then Add to add this application mode to the model.
4 Next select the RF Module>Perpendicular Waves>Hybrid-Mode Waves> Mode
analysis application mode. Add this mode to the model.

5 For convenience select Free space wavelength from the Specify wave using list. This
makes the wavelength available in the Application Scalar Variables dialog box instead of
the frequency.

6 Click OK.
The unknown parameters e0, e1, and e2 should be constant within the whole modeling domain.
You can achieve this by adding a new geometry with only a single point to the model and
define e0, e1, and e2 as the dependent variables at this point. Later on you define coupling
variables that map these dependent variables from the point to the whole model.

1 From the Multiphysics menu, select the Model Navigator. Click the Add Geometry
button to add a 2D geometry (2D is the default space dimension).

2 Select the COMSOL Multiphysics>PDE Modes>Weak Form, Point application mode
from the application mode tree.

3 Type e0 e1 e2 in the Dependent variables text field.
4 Click Add to add the Weak Form, Point application mode to the second geometry. This
application mode contains the three degrees of freedom for the parameters e0, e1, and e2
that describe the

z strain.

5 Set the Ruling application mode to the Perpendicular Hybrid-Mode Waves (rfwv)
application mode. This makes this application mode specify the interpretation of the
parameters to the eigenvalue solver given in the Solver Parameters dialog box.

6 Click OK to close the Model Navigator.
The Weak Form, Point application mode becomes the active application mode when you close
the Model Navigator.

GEOMETRY MODELING
The three degrees of freedom e0, e1, and e2 must be associated with a point. The location of
this point is insignificant. This means that the added geometry could equally well have been a
1D or a 3D geometry. Using the programming language, there is also an option of using a 0D
geometry.

file:///C:/COMSOL35a/doc/rf/optics_and_photonics_modlib.15.7.html

4/18/2018

Stress-Optical Effects with Generalized Plane Strain

Page 8 of 16

Add a point at any position, for example, the origin (0, 0), on the Geom2 page in the drawing
area.

OPTIONS AND SETTINGS
In the Constants dialog box enter the following names, expressions, and descriptions
(optional); when done, click OK. They are identical to the constants defined on page 261.
NAME

EXPRESSION

DESCRIPTION

nSi

3.5

Refractive index, silicon
(Si)

nBuf

1.445

Refractive index, silica
(SiO2)

nClad

1.445

Refractive index, silica

deltan

0.0075

Relative index difference:

nCore

nClad/sqrt
(1-2*deltan)

Refractive index, core

alphaSi

2.5e-6[1/K]

Thermal expansion
coefficient, silicon

alphaSiO2 0.35e-6[1/K]

Thermal expansion
coefficient, silica

ESi

110[GPa]

Young’s modulus, silicon

ESiO2

78[GPa]

Young’s modulus, silica

nuSi

0.19

Poisson’s ratio, silicon

nuSiO2

0.42

Poisson’s ratio, silica

B1

4.2e-12[m^2/N]

First stress optical
coefficient

B2

0.65e-12[m^2/N]

Second stress optical
coefficient

T1

20[degC]

Operating temperature

T0

1000[degC]

Reference temperature

GEOMETRY MODELING
1 Switch to Geom1 by clicking its tab.
2 Draw rectangles corresponding to the different regions.
REGION

LOWER LEFT CORNER

UPPER RIGHT CORNER

Silicon Wafer

(-16e-5,-1e-4)

(16e-5,-1.7e-5)
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Buffer

(-16e-5,-1.7e-5)

(16e-5,-3e-6)

Cladding

(-16e-5,-3e-6)

(16e-5,1.3e-5)

Core

(-3e-6,-3e-6)

(3e-6,3e-6)

PHYSICS SETTINGS

Point Settings and Boundary Conditions
All regions have free boundaries, which also is the default boundary condition. However, these
conditions do not suffice in creating a unique solution because the computational domain can
move and rotate freely; the problem is ill-posed. The problem becomes well-posed by adding
constraints at points to keep the domain fixed.

1 Select the Plane Strain (smpn) application mode from the Multiphysics menu.
2 From the Physics menu, choose Point Settings.
3 In the Point Settings dialog box, choose Point 1 and, on the Constraint page, select the
Rx and Ry check boxes to constrain the displacements in the x- and y-direction to zero in
the lower-left corner. This keeps the domain from moving (translational move).

4 Select Point 9 and then select the Ry check box to constrain the y direction only in the
lower-right corner, keeping the domain from rotating but allowing it to slide in the

x

direction.

5 When done, click OK.

Subdomain Settings
The air domain need not be part of the plane strain model.

1 From the Physics menu, choose Subdomain Settings.
2 Specify the subdomain settings for the Plane Strain application mode according to the
following table.
SUBDOMAIN 1

Page Material

SUBDOMAINS 2–4

Loads

E ESi

Material

Loads

E ESiO2

ν

nuSi

α

alphaSi Tempref T0 α

Temp

T1 ν

nuSiO2

Temp

T1

alphaSiO2 Tempref T0

Before entering the temperatures on the Load page, you must select the Include thermal
expansion check box. It is not necessary to specify the density ρ, because it does not
enter the equation for static problems.

3 Click OK.
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EXPRESSION VARIABLES
1 From the Options menu, choose Expressions>Subdomain Expressions.
2 In the Subdomain Expressions dialog box in the Options menu, define the following
variables; when done, click OK.
NAME

SUBDOMAIN
SELECTION

EXPRESSION

E

1

ESi

2–4

ESiO2

1

nuSi

2–4

nuSiO2

nu

alpha 1

alphaSi

2–4

alphaSiO2

ex

1–4

ux

ey

1–4

vy

ez

1–4

e00+e11*x+e22*y

sx

1–4

sx_smpn+E/((1+nu)*(1-2*nu))
*nu*ez

sy

1–4

sy_smpn+E/((1+nu)*(1-2*nu))
*nu*ez

sz

1–4

E/((1+nu)*(1-2*nu))*
(nu*ex+nu*ey+
(1-nu)*ez-(1+nu)*alpha*(T1T0))

N

1

nSi

2

nBuf

3

nCore

4

nClad

1

N

2–4

N-B1*sx-B2*(sy+sz)

1

N

2–4

N-B1*sy-B2*(sx+sz)

1

N

2–4

N-B1*sz-B2*(sx+sy)

Nx

Ny

Nz

The variables

ex, ey, and ez are the strains εx, εy, and εz, and the variables sx, sy, and

sz are the stresses σx, σy, and σz. The definitions of the refractive index variables Nx, Ny,
Nz differ slightly compared to the previous model. In this case they are expressed in
the generalized stress variables sx, sy, and sz. Because of the use of integration coupling
and
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e11, and e22), COMSOL Multiphysics cannot determine the unit for other

variables that directly or indirectly depend on these integration coupling variables. This
causes the warnings for inconsistent units here and in the specification of the refractive
index. You can disregard these warnings.

COUPLING VARIABLES
The unknown parameters e0, e1, and e2 should be constant within the whole modeling domain.
You can achieve this by defining coupling variables that map these dependent variables from
the point to the entire model:

1 Switch to Geom2 by clicking its tab.
2 Open the Point Integration Variables dialog box by selecting Integration Coupling
Variables>Point Variables from the Options menu.

3 Enter the following names and expressions, each on a separate row in the table on the
Source page.
NAME EXPRESSION

e00

e0

e11

e1

e22

e2

The variables

e00, e11, and e22 take the values of e0, e1, and e2, respectively, in the

entire model.

SUBDOMAIN SETTINGS
Finally, enter the additional terms in the generalized plane strain problem.

1 Switch to Geom1 by clicking its tab.
2 Select Equation System>Subdomain Settings from the Physics menu.
3 On the Weak tab in the Subdomain Settings - Equation System dialog box, add

-E/((1+nu)*(1-2*nu))*(ex_test*nu*ez+ey_test*nu*ez)-ez_test*sz in
the second row of the weak term for all subdomains. The two first rows correspond to the
plane strain problem. You can enter this expression in any of these two fields, because the
software adds them together when assembling the problem.

4 Click OK.

MESH GENERATION
1 Initialize the mesh by clicking the Initialize Mesh button on the Main toolbar.
2 Refine it twice by clicking the Refine Mesh button on the Main toolbar twice.
3 Switch to Geom2 by clicking its tab.
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4 Initialize the mesh in this geometry too.

COMPUTING THE SOLUTION
1 From the Solve menu, choose Solver Parameters.
2 In the Solver Parameters dialog box select the Stationary solver. When done, click OK.
3 From the Solve menu, choose Solver Manager.
4 On the Solve For tab in the Solver Manager dialog box, select only the Plane Strain and
the Weak Form, Point (wp) application modes. This excludes the hybrid-mode waves
application mode from the equations to solve. When done, click OK.

5 Click the Solve button, then click OK.

POSTPROCESSING AND VISUALIZATION
1 Switch to Geom1 by clicking its tab.
2 From the Postprocessing menu, choose Plot Parameters.
3 Click the Surface tab on the Plot Parameters dialog box. Change the string in the
Expression edit field on the Surface Data page to

abs((ex-ez)/ez)<0.05. Clear the

Smooth check box. Click OK to visualize the area where the relative difference between
the

x and z strain is within 5%. The model is most accurate in the regions close to the core,

far from the boundaries on the far left and right.

4 For symmetry reasons the strains εx and εz should be equal. To see how well this model has
achieved this, make a cross-section plot of them. Open the Cross-Section Plot
Parameters dialog box from the Postprocessing menu. Enter the Title
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using the Title/Axis dialog box on the General page. On the Line/Extrusion tab, set x0

0, x1 to 0, y0 to -1e-4, and y1 to 1.3e-5 to make a vertical line across the
ex, and set the Line resolution to 25. Set
the x-axis data to y. Click the Line Settings button and select Circle as Line marker;
then click OK. Click Apply to plot ex.
to

structure. Enter the y-axis data expression

5 On the General tab check Keep current plot to be able to plot ez in the same figure
window.

6 Then change the Expression to ez in y-axis data. Use Plus sign as Line marker for this
plot. Click OK to make the plot.

7 To view the stress-induced birefringence nx − ny together with the deformation, open the
Plot Parameters dialog box and select the Surface and Deformed shape check boxes in
the Plot type area. On the Surface page, enter the

Nx-Ny in the Expression edit field

on the Surface Data page, and select the Smooth check box again. In the Deformation
data area, choose Plane Strain (smpn)> Displacement from the Predefined
quantities list on the Subdomain Data page, which is the default selected on the
Deform tab. Click OK.
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Note: This model includes an extension of the plane strain PDE system. This means that some
of the postprocessing variables in the Plane Strain application mode are no longer valid and
give wrong results if used. We recommend that you use only the variables entered in the
Subdomain Expressions dialog box for postprocessing.

Modeling Using the Graphical User Interface—Optical Mode
Analysis
Continue with the mode analysis in the same way as in the previous model on page 268.

GEOMETRY MODELING
You can reduce the computational domain significantly for the optical mode analysis because
the energy of the fundamental modes is concentrated in the core region, and the energy
density decays exponentially in the cladding and buffer regions.
Draw a rectangle with corners at (-1e-5, -1e-5) and (1e-5, 1e-5) on the Geom1 page.

PHYSICS SETTINGS
Next, set up the parameters for the hybrid-mode wave problem. Select the Perpendicular
Hybrid-Mode Waves (rfwv) application mode in the Multiphysics menu.

Scalar Variables
1 From the Physics menu, choose Scalar Variables.
2 In the Application Scalar Variables dialog box, set the Free space wavelength to

1.55e-6. Click OK.

Subdomain Settings
1 From the Physics menu, choose Subdomain Settings.
2 Deactivate the Perpendicular Hybrid-Mode Waves application mode in all subdomains
except 4, 5, and 6 (clear the Active in this domain check box for those subdomains). This
makes sure that the solution for the electromagnetic waves only includes the newly drawn
rectangle.

3 For all active domains, select the Specify material properties in terms of refractive
index button. Enter the values for

Nx, Ny, and Nz, respectively, as anisotropic refractive
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indices by selecting Diagonal from the Anisotropy list in the extended n edit field and
changing the entries on the diagonal in the refractive index matrix

4 When done, click OK.

EXPRESSION VARIABLES
Occasionally the associative geometry algorithm does not update all variables and settings
exactly as expected when modifying the geometry. In this case the expression for

N might

have got the wrong value in domain 6. In the Subdomain Expressions dialog box change
the value of

N in Subdomain 6 to nCore.

MESH GENERATION
1 From the Mesh menu, choose Free Mesh Parameters.
2 On the Subdomain tab in the Free Mesh Parameters dialog box, set the Maximum
element size to

2e-6 for Subdomains 4 and 5, and to 2.5e-7 for Subdomain 6.

3 Click the Remesh button to initialize the mesh, then click OK.

COMPUTING THE SOLUTION
1 From the Solve menu, choose Solver Parameters.
2 In the Solver Parameters dialog box, select the Eigenvalue solver.
3 Enter 1.46 in the text field Search for effective mode indices around. The default
Desired number of effective mode indices is set to

6, which is fine. Click OK.

These settings make the eigenmode solver search for the 6 eigenmodes with effective
mode indices closest to the value

1.46. This value is an estimate of the effective mode

index for the fundamental mode. For propagating modes it must hold that

4 From the Solve menu, choose Solver Manager.
5 In the Solver Manager dialog box, select only the Perpendicular Hybrid-Mode Waves
(rfwv) application mode on the Solve For page. This ensures that only this application
mode is part of the eigenmode computation.

6 On the Initial Value page, set the initial value to Current solution in the Initial value
area. This takes the plane strain solution and uses it to evaluate the refractive indices for
the mode analysis.

7 Click the Solve button, then click OK.
The following table contains the effective mode indices together with the effective mode
indices obtained from the analysis in the previous model without the generalization of the
plane strain equations.
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GENERALIZED PLANE STRAIN DIFFERENCE
PLANE STRAIN
EFFECTIVE MODE INDEX

*1e-3

neff1

1.444923

1.444873

-.05

neff2

1.445195

1.445134

-.06

neff3

1.445213

1.445138

-.07

neff4

1.445487

1.445399

-.09

neff5

1.450928

1.450871

-.06

neff6

1.451217

1.451135

-.08

There is a systematic shift in the propagation constants when the strain in the

z direction is

taken into account.
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